Failed to resolve: taplinx-android:nxpnfcandroidlib:1.7

Forum / MIFARE SDK / Failed to resolve: taplinx-android:nxpnfcandroidlib:1.7

Tagged: , ,

  • 5. October 2020 at 11:38
    I am getting this error while adding dependency in my android project.

    Failed to resolve: taplinx-android:nxpnfcandroidlib:1.7
    Show in Project Structure dialog
    Affected Modules: Application, cardreading


    Here's my gradle file
    allprojects {
    repositories {
    flatDir {
    dirs 'libs'
    }
    mavenCentral()
    maven { url "https://jitpack.io" }
    maven { url "https://s3.amazonaws.com/repo.commonsware.com" }
    /** Following lines are for accessing the TapLinx jars from Repo directly */
    maven {
    credentials {
    username "sdkuser"
    password "taplinx"
    }
    url "http://maven.taplinx.nxp.com/nexus/content/repositories/taplinx/"
    }
    google()
    jcenter()

    }
    }

    dependencies {
    implementation fileTree(dir: 'libs', include: ['*.jar'])

    api('taplinx-android:nxpnfcandroidlib:1.7@aar') {
    transitive = true
    }

    testImplementation 'junit:junit:4.12'
    androidTestImplementation 'androidx.test:runner:1.1.0'
    androidTestImplementation 'androidx.test.espresso:espresso-core:3.1.0'
    }
    + 0  |  - 0

    Re: Failed to resolve: taplinx-android:nxpnfcandroidlib:1.7

    5. October 2020 at 14:44
    Hi Chintan,

    We were asked to modify our release procedure and therefore the Maven repo is currently not available. But you can download the AAR library and add it to your project. The AN (see link below) explains how bind the AAR library to your project.

    It is explained in the AN how to include TapLinx AAR file into your project. It is the same as you use any other third party library. For TapLinx you muss add a line to Gradle manually to refer to the Firebase library.

    Please have a look to this AN:

    https://www.mifare.net/wp-content/uploads/2020/09/AN11876.pdf

    Look to section: 3.2.2 Modifications in the project files for the “AAR Library” approach.

    The TapLinx team

    + 0  |  - 1

    Re: Failed to resolve: taplinx-android:nxpnfcandroidlib:1.7

    5. October 2020 at 17:46
    I am not able to add 1.7 version aar file as module. can you provide the newer/older version of the AAR file.
    + 0  |  - 0

    Re: Failed to resolve: taplinx-android:nxpnfcandroidlib:1.7

    6. October 2020 at 12:28
    Hi Chintan,
    You should open the project structure dialog in Android Studio and click on “+” button shown below:



    Then opens a dialog where you select the previously downloaded AAR file. As last step you must add the TapLinx module into the dependency list. That’s it. Do not forgot the add the reference to the Firebase library. All of this is explained in the AN: Starting development with TapLinx .

    The TapLinx team
    Attachments:
    You must be logged in to view attached files.

    + 0  |  - 0
Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.