Problems switching Mifare Plus S 2K to SL1

Forum / MIFARE and NFC Reader IC`s / Problems switching Mifare Plus S 2K to SL1

  • 29. September 2018 at 16:19

    I have to switch Mifare Plus S 2K to SL1 from SL0 using Omnikey 5421 reader. It seems I am unable to command the card to use the writeperso/commitperso sequence to switch the security level. I have no issues doing this using an Android phone with transceive, however I am unable to do so using Omnikey with generic session APDUs. Once the cards are personalized with the Android phone I can read/write them with SCardTransmit with the reader, so the reader appears to work fine.

    I have tried to enter/exit generic session as per documentation: FFA0000703010001 for entry, FFA0000703010002 for exit. The reader reports 0x9000 to both commands.

    However, when using FFA00005 (6+n) 0100F3000064 (MIFARE Plus command) 00 I have issues (this is the generic session apdu command for this particular reader). If I put the last 00 in the command, the reader always responds with 0x6400 (command timeout). If I leave out the 00 at the end, the reader always responds with 0x9000, but no other return data (for example, 14443a status 90 - command executed ok). If I make up commands the reader always returns 0x9000 provided the last 00 is ommited.

    If I run a RATS command as per documentation FFA00005080100F3000064E08100 the return is 0x6400. If I run it without the last 00, meaning FFA00005080100F3000064E081, the response is 0x9000, but no other output. However, if I run the full RATS command (including the last 00) on an already personalized card moved to SL1, some output from the RATS command is shown (00000C7xxxx...), so the channel seems to work, just not for a card in SL0.

    If I run the writeperso/commitperso commands in blind nothing happens, all commands return 0x9000 but the card is unchanged.

    Is there something else that I have to pass to the card before beginning the writeperso/commitperso sequence?

    + 0  |  - 0

    Re: Problems switching Mifare Plus S 2K to SL1

    2. October 2018 at 9:41
    Hi Daniel,

    Please download the HID Reader Manual and check the APDU sequences. For Omnikey readers, APDU sequences for some cards must be wrapped into another APDUs. You need the manual for all details.

    The TapLinx team

    + 0  |  - 0

    Re: Problems switching Mifare Plus S 2K to SL1

    3. October 2018 at 10:04

    I am already encapsulating 0xa8 and 0xaa command apdus in the "generic session" apdus according to Omnikey documentation, but it does not seem to work. I just thought that maybe someone faced the same problem.

    + 0  |  - 0

    Re: Problems switching Mifare Plus S 2K to SL1

    7. October 2018 at 12:49
    i am in the same problem and I can't find any solution for this problem
    can you please help if you find any solution
    thanks in advance
    + 0  |  - 0
Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.