Mifare Desfire ISO SELECT FILE Command

Forum / MIFARE SDK / Mifare Desfire ISO SELECT FILE Command

  • 16. November 2016 at 23:47
    I am trying to understand the usage of ISO SELECT FILE command on Desfire EV1 tag. I am refering to documentation page no 98 of 114. This page explain how to use FCI and I have tried using all commands but could not get value of FCI. I just a response 90 00. The document suddenly mentions of command SELECT DF command? is this a different command? I tried using P2=00, P1=0 and I have a file created with ID mentioned in the document. I am not able to get FCI file content.

    Any help appreciated
    + 0  |  - 0

    Re: Mifare Desfire ISO SELECT FILE Command

    17. November 2016 at 9:33
    Hi Narendc,

    The ISO commands are available for compatibility reasons of ISO7816-4. All ISO commands are wrapped to native commands on a DESFire. If you do not need to be compatible to ISO, I recommend to use the native DESFire commands.

    The ISO7816-4 allows it to deal with files either with IDs or with DF names. That is the reason for the two types of commands.

    Kind regards,
    The TapLinx Team
    + 0  |  - 0

    Re: Mifare Desfire ISO SELECT FILE Command

    17. November 2016 at 11:42
    Looks like my question was not clear. The feature that is explained in that section of the document is not available in native commands. Indeed that is a very good feature the document says this. When we select a application not only we get status 90 00 but also the content of a file with id 31 in that application folder.

    With native command I have to do two separate request to achieve this. All I am asking is, since the document mentions about this feature of ISO commands, I could not reproduce it. If anybody in your tech support have done this, then I would like to know how?

    + 0  |  - 0
Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.